I just noticed something funny in the comments to this question:


See the messy "scratches" on each end of the OP's username? I'm pretty sure they're not supposed to be there.

The reason this happens is because the same CSS class, owner, is used to style both the OP's username in the comments and the fancy box containing the OP's user card below the question. The "mess" in the comment username is simply a small slice of the background image intended for the user card:


A simple CSS fix would be to disable the background image for comments, like this:

a.comment-user.owner {
    background-image: none;

This will eliminate the messy background image, but will leave the solid background color in place.

Ps. Ugh, I just noticed that the code block above looks really ugly, because the background color for <code> tags here on meta.ELU is set to #e0e0e0, while that of the surrounding <pre> block is #eee (which is shorthand for #eeeeee). It doesn't seem to happen on the main site, where both have a background color of #eee. This could be fixed either by making the colors match, or by adding an extra rule to remove the background entirely from <code> inside <pre>, like this:

pre code {
    background: transparent;

Pps. Both of the CSS fixes above are now included in the SOUP v1.14 user script.

Ahah! I was wondering what was actually going on there. Thanks for sleuthing it out. – tchrist May 4 '14 at 14:35
I'm voting to close this question as off-topic because it is no longer true. The problem has since been fixed. – Mari-Lou A Jun 25 at 15:15
Ahh, "status completed" tag. Hadn't noticed that, so why is the post still open? – Mari-Lou A Jun 25 at 15:16
@Mari-LouA: Because resolved bug reports aren't traditionally closed, and also because there's no standard close reason for it on per-site metas. (There is a "no longer reproducible" close reason on meta.SE and meta.SO which sometimes gets used, if the mods forget to add the status-completed tag.) I suppose I should self-answer this and accept it, just so it won't get bumped by Community ♦ later. – Ilmari Karonen Jun 25 at 15:41
Retracted close vote. Thank you for answering so swiftly. :) – Mari-Lou A Jun 25 at 15:49

1 Answer 1

up vote 1 down vote accepted

It seems that both of these issues have been fixed at some point, probably as a side effect of the general SE design rework carried out in spring. Owner comments now have a solid-color background, and the background color of <pre> and <code> tags is now consistently #eee.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .